no me redirecciona a mis subdominios

Inicio Foros Foro de GeekLab (Español) no me redirecciona a mis subdominios

Viendo 10 entradas - de la 1 a la 10 (de un total de 10)
Autor Entradas
Autor Entradas
31/05/2013 at 15:11 #1237

pandatlax

he instalado siguiendo la guia de http://wp.geeklab.com.ar/gl/2013/05/09/como-instalar-gnupanel-en-debian-wheezy/ en debian wheezy con el tar gnupanel_lenny_squeeze_wheezy_precise_0.3.5_R1.tar todo a ando correcto en la instalacion pero al crean un subdominio en el usuario y tipear el subdominio http://misub.dominio.com no me direcciona a la carpeta raiz de ese subdominio y solo me pone una pagina en gris del gnupanel y al hacer un ping al subdominio me responde la ip publica del servidor osea que los dns de fuera si estan bien pero los internos o el routeo interno no me esta funcionando otra cosa curiosa es que al terminar de crear al usuario y su panel en las versiones anteriores automanticamente se activava el protocolo seguro para entrar a los paneles por https y en esta ocacion no entro por http normal alguien me podria ayudar a solucionar esto de antemano muchas gracias

02/06/2013 at 7:09 #1243
SysAdmin
SysAdmin

Hola,

Perdona la demora en responder

El servidor esta detras de un router? tienes una IP publica y una privada?

revisa estos dos archivos

/var/log/gnupanel-install.err
/var/log/gnupanel-install.log

Para ver si tenemos alguna pista de lo que puede estar pasando.

Con respecto al https en las ultimas versiones gnupanel acepta los dos ingresos a la vez http y https.

Saludos.

03/06/2013 at 16:01 #1249

pandatlax

no esta atras de router y tiene solo una ip publica, pero podria ponerle una privada y que la red privada si este atras de un router pero la publica es directa

en el archivo .err

este es el contenido
Generating a 1024 bit RSA private key
.++++++
……….++++++
writing new private key to ‘/etc/proftpd/proftpd.key.pem’
—–
ln: fallo al crear el enlace simbólico «/var/lib/gnupanel/etc/apache2/sites-ebled/999999999999-default»: El fichero ya existe
PID ilegible en: /var/run/mailman/mailman.pid
[Errno 2] No such file or directory: ‘/var/run/mailman/mailman.pid’
�Est� el qrunner corriendo acaso?
363 semi-random bytes loaded
Generating RSA private key, 1024 bit long modulus
………++++++
………++++++
e is 65537 (0x10001)
Signature ok
subject=/C=AR/ST=BUENOS AIRES/L=CAPITAL FEDERAL/O=GNUPANEL/OU=GNUPanel/CN=gnupanel.org/emailAddress=rmalvarez@gnupanel.org
Getting Private key
Generating a 1024 bit RSA private key
………………..++++++
…++++++
writing new private key to ‘cakey.pem’
—–
psql: FATAL: database «gnupanel» does not exist
ln: fallo al crear el enlace simbólico «/etc/courier/imapd.pem»: El fichero ya existe
ln: fallo al crear el enlace simbólico «/etc/courier/pop3d.pem»: El fichero ya existe

y el log dice esto

Setting kernel variables …done.
Configurando postgresql-9.1
Configuring postgresql-9.1
Restarting PostgreSQL 9.1 database server: main.
Configurando mysql
Configuring mysql
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld ..
Checking for tables which need an upgrade, are corrupt or were
not closed cleanly..
Configurando powerdns
Configuring powerdns
update-rc.d: using dependency based boot sequencing
Starting PowerDNS authoritative nameserver: started
Configurando proftpd
Configuring proftpd
Stopping ftp server: proftpd.
El directorio /etc/proftpd ya existe
Starting ftp server: proftpd.
Configurando apache2
Configuring apache2
Stopping web server: apache2 … waiting .
Module authz_user already enabled
Module php5 already enabled
Enabling module ssl.
See /usr/share/doc/apache2.2-common/README.Debian.gz on how to configure SSL and create self-signed certificates.
To activate the new configuration, you need to run:
service apache2 restart
Enabling module rewrite.
To activate the new configuration, you need to run:
service apache2 restart
Module auth_pam already enabled
Module auth_basic disabled.
To activate the new configuration, you need to run:
service apache2 restart
Starting web server: apache2.
Configurando mailman
Configuring mailman
Clave nueva de mailman: xxxxxxxxxxxxxx
Restarting Mailman master qrunner: mailmanctl.
Configurando postfix
Configuring postfix
Stopping Postfix Mail Transport Agent: postfix.
Stopping amavisd: (not running).
Stopping SASL Authentication Daemon: saslauthd.
Stopping Courier IMAP-SSL server: imapd-ssl.
Stopping Courier POP3-SSL server: pop3d-ssl.
Stopping Courier IMAP server: imapd.
Stopping Courier POP3 server: pop3d.
Stopping Courier authentication services: authdaemond.
Stopping ClamAV daemon: clamd.
Stopping ClamAV virus database updater: freshclam.
Añadiendo el grupo `correos’ (GID 4001) …
Hecho.
passwd: información de caducidad de la contraseña cambiada.
Añadiendo al usuario postfix' al gruposasl’ …
Añadiendo al usuario postfix al grupo sasl
Hecho.
Añadiendo al usuario amavis' al grupoclamav’ …
Añadiendo al usuario amavis al grupo clamav
Hecho.
Añadiendo al usuario clamav' al grupoamavis’ …
Añadiendo al usuario clamav al grupo amavis
Hecho.
/var/lib/gnupanel/config/wheezy/etc/postfix/ssleay.cnf
WhHfT5FtMAs75
365

Añadiendo al usuario www-data' al grupopostfix’ …
Añadiendo al usuario www-data al grupo postfix
Hecho.
Starting ClamAV virus database updater: freshclam.
Starting ClamAV daemon: clamd .
Starting Courier authentication services: authdaemond.
Starting Courier POP3 server: pop3d.
Starting Courier IMAP server: imapd.
Starting Courier POP3-SSL server: pop3d-ssl.
Starting Courier IMAP-SSL server: imapd-ssl.
Starting SASL Authentication Daemon: saslauthd.
Starting amavisd: amavisd-new.
Starting Postfix Mail Transport Agent: postfix.
Stopping amavisd: amavisd-new.
Starting amavisd: amavisd-new.
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
Configurando Courier
Configuring Courier
Stopping Courier IMAP-SSL server: imapd-ssl.
Stopping Courier POP3-SSL server: pop3d-ssl.
Stopping Courier IMAP server: imapd.
Stopping Courier POP3 server: pop3d.
Stopping Courier authentication services: authdaemond.
Ya existe un certificado
Ya existe un certificado
Starting Courier authentication services: authdaemond.
Starting Courier POP3 server: pop3d.
Starting Courier IMAP server: imapd.
Starting Courier POP3-SSL server: pop3d-ssl.
Starting Courier IMAP-SSL server: imapd-ssl.

y no hayo algo ustedes si ??

04/06/2013 at 3:27 #1251
SysAdmin
SysAdmin

Hola,

Si puedes peganos el contenido del archivo /etc/gnupanel/GNUPANEL_INSTALL_DATA reemplaza los passwords por XXXXXXXX

Saludos.

04/06/2013 at 16:26 #1252

pandatlax

si el contenido es el siguiente

GNUPANEL_PG:XXXXXXXX
PROFTPD_PG:XXXXXXXX
PDNS_PG:XXXXXXXX
APACHE_PG:XXXXXXXX
POSTFIX_PG:XXXXXXXX
MYSQL_PASSWD:xxxxxxxx
IP:148.223.146.25
IP_INTERNET:148.223.146.25
IP_DNS_PROVEEDOR:148.223.146.30
IP_ALLOW_RECURSION:
DOMINIO_PRINCIPAL:dominio.org.mx
CORREO_ADMIN:webmaster@donimio.org.mx
PALABRA_CLAVE:xxxxxxxxxxx
CONTRASENA_MAILMAN:xxxxxxxxxx
NOMBRE_SERVIDOR:sfpweb
TRANSFERENCIA_SERVIDOR:340000000000
ESPACIO_SERVIDOR:272225
CONTRASENA_ADMIN:xxxxxxxxxxx

04/06/2013 at 20:04 #1253
SysAdmin
SysAdmin

Como tienes configurados los DNSs en tu proveedor de dominios?

recuerda que como DNS primario debes tener

ns1.dominio.org.mx apuntando a 148.223.146.25

Saludos.

P.D.: Edite tu post y le saque los password que no habias quitado.

04/06/2013 at 22:20 #1256

pandatlax

a ok tengo como ns1 148.223.146.30 pero no me habia pasado asi tengo montado en otro server un dominio el cual apunta al .30 y ese si resuelve dns muy bien, probare poner asi haber si resulta gracias

P.D. los pass estaban incompletos les quite solo parte de ellos xD por eso los habia puesto completos

05/06/2013 at 0:10 #1258

pandatlax

ya realice la prueba apuntando el dominio directo al server y sigo con lo mismo, con un poco de ayuda tecnica de unos amigos me comentan que es error del apache y del virtual host del mismo, algun cable que me pudieran dar para poder solventar esto ?

05/06/2013 at 23:02 #1263
SysAdmin
SysAdmin

Si puedes péganos el dominio el subdominio y tu IP así podemos chequear si es un problema de DNS.

Saludos.

18/06/2013 at 17:14 #1323

pandatlax

lamento haberme ausentado, me tenia liado con este tema y termi haciendo una instalacion nueva de mismas plataformas pero en una red y server diferentes y todo bien, al parecer sera un conflicto en la red anterior lo que no me estaba resultando de todos modos gracias por su apoyo y seguire un poco mas el foro por si pudiera ayudar en algo posteare otra duda en unos minutos gracias por la ayuda

Viendo 10 entradas - de la 1 a la 10 (de un total de 10)

Debes estar registrado para responder a este debate.