ERROR con WordPress al intentar actualizar plugin o version

Inicio Foros Foro de GeekLab (Español) ERROR con WordPress al intentar actualizar plugin o version

Viendo 10 entradas - de la 1 a la 10 (de un total de 10)
Autor Entradas
Autor Entradas
10/01/2013 at 1:12 #125

pillo

Hola

Estupendo que el proyecto GNUPanel sigue.

Tras una instalación limpia debian 6 (squeeze) GNUPanel 0.3.2 Estable. Todo perfecto instalación sin fallos funciona todo. Tras perfecto instalación y configuración me da un ERROR con WordPress al intentar actualizar plugin o version me arroja este error:

2013 Jan 23 11:45:14 servidorespillo ALERT – function within blacklist called: set_time_limit() (attacker ‘212.225.142.213’, file ‘/var/www/sitios/admin/servidorespillo@servidorespillo.com/cordobaclick.es/subdominios/www/wp-admin/includes/class-wp-upgrader.php’, line 174)

El error es ALERT – function within blacklist called: set_time_limit() (attacker ‘212.225.142.213’

En todos los dominios creados no puedo actualizar ningún WordPress

 

Gracias

Saludos

26/01/2013 at 8:45 #291
SysAdmin
SysAdmin

Hola, perdona por la demora en responder, todavía no me habituó a usar el bbpress

Eso ocurre por que en el archivo /etc/gnupanel/gnupanel.conf.pl tienes algunas funciones bloqueadas, debes editar ese archivo en la linea que dice esto


$funciones_prohibidas = "proc_open,popen,disk_free_space,diskfreespace,set_time_limit,leak,tmpfile,exec,system,shell_exec,passthru";

Y le quitas las funciones que no quieres que PHP bloquee una cosa a tener en cuenta es que si no quieres que bloquee ninguna función debes colocar none, pues si lo dejas con una cadena vacía apache dará un error.


$funciones_prohibidas = "none";

luego de modificar el archivo ejecutas el comando

/etc/init.d/gnupanel-transf restart

y luego te logueas en la base de datos para ejecutar una consulta

Como root ejecutas los siguientes comandos


su postgres
psql gnupanel
UPDATE gnupanel_apacheconf SET estado = 0;
\q
exit

Luego esperas uno o dos minutos y ya debería funcionar todo.

Saludos.

26/01/2013 at 14:19 #294

pillo

Muchísimas gracias.

Todo perfecto ahora ya no sale el error y puedo actualizar.

Saludos.

15/02/2013 at 3:11 #589

Samael

Hola, me ocurrió lo mismo lo modificaba en php.ini pero no bajo todo lo que necesito, veo que en la base de datos el parámetro que actualiza (estado) lo cambia de 9 a 0, es factible solo cambiar ese parámetro a un dominio X sin bajar la seguridad a todo el servidor, así tener solo esa baja de seguridad solo en ese dominio?

Gracias.

15/02/2013 at 5:06 #593
SysAdmin
SysAdmin

Hola,

Lamentablemente ese parámetro es común a todos los dominios, lo único que podrías hacer es editar manualmente el archivo de configuración de apache que pertenezca a ese subdominio, ( en este directorio /var/lib/gnupanel/etc/apache2/sites-available/ ).

Saludos.

15/02/2013 at 5:14 #594

Samael

Postgre tiene alguna seguridad para modificación en el panel?, genero el cambio me dice que se actualizo espero mucho tiempo y en la bd sigue estando el 9 y con los parámetros bloqueados, no actualiza el cambio.
$funciones_prohibidas = «none»;
/etc/init.d/gnupanel-transf restart
su postgres
psql gnupanel
UPDATE gnupanel_apacheconf SET estado = 0;
\q
exit
Me dice UPDATE 59 pero no las cambia quedan igual y espero 1 hora y nada incluso con reinicio después de 2 horas.

Gracias.

15/02/2013 at 22:59 #597
SysAdmin
SysAdmin

Revisa en la configuración de los dominios ( en este directorio /var/lib/gnupanel/etc/apache2/sites-available/ ) si esta esta linea

php_admin_value suhosin.executor.func.blacklist none

o la tienes con el listado completo de funciones bloqueadas.

Saludos.

16/02/2013 at 0:13 #598

Samael

Esta en none
php_admin_value suhosin.executor.func.blacklist none
Entonces nada tiene que ver que no cambie en la BD el «estado» de 9 a 0?

Gracias.

16/02/2013 at 11:54 #599
SysAdmin
SysAdmin

Hola,

Perdona es que no había entendido, el demonio que configura apache lee periódicamente la columna estado, cuando esa columna tiene un valor 9 no hace nada cuando le pones el valor 0 el demonio configura o reconfigura el subdominio y luego le vuelve a colocar el valor 9.

Saludos.

16/02/2013 at 20:29 #601

Samael

Vale, muchas gracias.

Viendo 10 entradas - de la 1 a la 10 (de un total de 10)

Debes estar registrado para responder a este debate.